A IP address and were actively responding to pings after VM was removed from VC
A thorough search of IP and MAC in vCenter inventory and across all ESXi hosts yielded no registered Virtual Machine
This situation was causing a significant conflict, preventing a legitimate VM from being assigned and utilizing this IP details
Environment
VMware vSphere ESXi
Cause
Investigation identified the cause as a "rogue" or "phantom" VM process operating directly on an ESXi host
Even though the virtual machine was not registered or visible within vCenter, its underlying processes were still running. These orphaned processes were actively holding the conflicting IP and MAC addresses
Resolution
To resolve the issue, follow the below steps;
Step 1:
Connect to ESXi host via SSH
Run ps | grep -i <vm_name> command and make a note of the VM process ID
Step 2:
Run the following command to forcefully kill the main process: kill -9 <Process_ID>