HCX UI reports an alert related to the "uplink lossRate"
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HCX UI reports an alert related to the "uplink lossRate"

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Article ID: 415669

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Updated On:

Products

VMware HCX

Issue/Introduction

  • An alert indicating that the “lossRate” for a specific uplink has exceeded the threshold is reported on the HCX UI.
    Message: HCX Underlay - uplink lossRate is above the threshold limit for uplink: <uplink name>


  • A log indicating that the alert was triggered is logged in app.log.
    /common/logs/admin/app.log
    <timestamp> UTC [InterconnectService_SvcThread-301395, J:2143e097, , TxId: <UUID>] INFO  c.c.s.m.j.c.v.h.i.u.InterconnectUnderlayEventUtil- handleUnderlayEventAlerting: eventCode LOSS_EXCEEDED

Environment

VMware HCX

Cause

  • This was caused by the packet loss rate exceeding the threshold on the route between sites in the service mesh appliance using the "Uplink" network profile.
  • This may also occur with network types other than "Uplink" network profile.
  • The alert will be cleared when the packet loss rate falls below the threshold.

Resolution

You need to investigate the underlay network between appliances or sites that are applying the network profile occurring packet loss.

To troubleshoot the alert related to HCX Service Mesh IX/NE appliances, you can follow these steps:

1. SSH to HCX Manager.

2. Run the ccli command to enter the ccli mode.
  <ccli>

3. Run the list command to list the NE/IX appliances registered to the HCX Manager
  <list
  
Note: Make a note of the NE/IX "node id" number to ssh to the respective appliance.

4. Run the command "go <node-id>" obtained in the above steps.
Note: The <node-id> is the id of the NE/IX appliance we want to ssh to.

Example:

# go 1

where 1 is the node id of the NE/IX appliance.

5. Run the command 'ssh' to ssh the appliance.

# ssh

6. Use the following commands to test connectivity.

1. ping <Peer IP>
2. traceroute <Peer IP>
3. mtr <Peer IP>