SMTP Outbound Connection Test Validation Failed with Error "Test was not successful: Email test error: [535 5.7.8 Error: authentication failed: authentication failure ]"
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SMTP Outbound Connection Test Validation Failed with Error "Test was not successful: Email test error: [535 5.7.8 Error: authentication failed: authentication failure ]"

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Article ID: 415661

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • SMTP Outbound Connection Test Validation Fails with Error "Test was not successful: Email test error: [535 5.7.8 Error: authentication failed: authentication failure ]"
  • Trying with different email account gives the same error.
  • The same account works fine when logging into email client.
  • The analytics logs displays below events:
    analytics-.log:2025-10-08T08:01:06,104+0000 ERROR [ServerConnection on port 10000 Thread 4710]  com.vmware.vcops.plugins.filter.EmailPlugin.test - Email test failed: [Could not connect to SMTP host: mail.domain.co, port: 587] 
    analytics-.log:2025-10-08T08:01:12,904+0000 ERROR [ServerConnection on port 10000 Thread 4710]  com.vmware.vcops.plugins.filter.EmailPlugin.test - Email test failed: [Could not connect to SMTP host: mail.domain.co, port: 587] 
    analytics.log:2025-10-08T08:01:15,577+0000 ERROR [ServerConnection on port 10000 Thread 4710]  com.vmware.vcops.plugins.filter.EmailPlugin.test - Email test failed: [Could not connect to SMTP host: mail.domain.co, port: 587]
  • We are able to connect via Openssl Command:
    openssl s_client -connect mail.domain.co:587 -starttls smtp
  • Running the below command fails to connects to the SMTP server with 'Error: authentication failed: authentication failure|Login denied'
    curl --url "smtp://mail.domain.co:587" --ssl-reqd --user '[email protected]:Password' --mail-from "[email protected]" --mail-rcpt "[email protected]" --verbose  

Environment

Aria Operations 8.17.X and Later

Cause

  • The authentication failures is seen on the mail server due to the following reasons:
    • Rate limiting or temporary lockout of the sender account

    • IP-based throttling or authentication caching

    • Load balancing across multiple mail nodes, where one backend node intermittently fails authentication

Resolution

  • Reach out to the SMTP provider to identify and resolve the issue.