Unable to Log In to vIDM Due to "Out of Memory" Issue
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Unable to Log In to vIDM Due to "Out of Memory" Issue

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Article ID: 415646

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Users may experience login failures to VMware Identity Manager (vIDM) due to the application becoming unresponsive or slow. 

Environment

VMware Identity Manager 3.3.7

Cause

Excessive heap memory is retained by the ElasticsearchClusterStatusImpl class due to large JSON objects not being properly garbage collected, leading to gradual memory buildup and service unresponsiveness.

Resolution

Workaround: 

Restart the vIDM service on all nodes to clear the retained memory.

service horizon-workspace restart

Note: Restarting the service will cause a temporary outage of the vIDM service.

Engineering is aware of this issue and is actively working on a permanent fix.