Users unable to login to Aria Automation due to vIDM error "Unable to obtain access policy"
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Users unable to login to Aria Automation due to vIDM error "Unable to obtain access policy"

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Article ID: 415640

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Users are unable to login to Aria Automation.

Even before any login prompt, users are displayed with vIDM error: 

An error occurred during OAuth2 operation. Please contact your administrator to resolve the issue.

{ "error": "server_error", "error_description": "Unable to obtain access policy" }

Environment

VMware Identity Manager 3.3.7

Aria Automation 8.x

Cause

Issue can be caused by expired passwords on the vIDM accounts 'root' and 'sshuser'.

Resolution

Reset the 'root' and 'sshuser' account passwords on all vIDM machines using the below commands.

  • passwd root
  • passwd sshuser

Update the new passwords in Lifecycle by following the steps in KB: Remediating passwords updated outside of VMware Aria Suite Lifecycle

This should clear the error at user login of Aria Automation.