PAM A2A Client returning garbled\unclear password
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PAM A2A Client returning garbled\unclear password

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Article ID: 415629

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Privileged Access Management (PAM) Admin is troubleshooting why A2A returns a 400 return code, but the password is unclear/garbled characters and not the actual password.

Cause

Zscaler Web Proxy Policy was blocking the successful retrieval.

Resolution

Whitelisted our A2A Agent (cspmclient/cspmclient64) in your Zscaler Web Proxy.

 

Additional Information

Inside the cspm_c_client_log.txt in FINE mode the following was captured in our log:

parseCredentialsFromDaemon: Input string: Your organization has selected Zscaler to protect you from internet threats.