Aria Operations for Logs UI will not load for primary node
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Aria Operations for Logs UI will not load for primary node

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Article ID: 415568

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

After upgrading Aria Operations for Logs the UI will not load for the primary node.  The UI for worker node loads up fine.

Runtime.log shows:

[FATAL] [com.vmware.loginsight.daemon.LogInsightDaemon] [Error starting services] com.vmware.loginishgt.daemon.LogInsightDaemonStartupFailedException: Daemon startup failed:  Failed to start Tomcat: /usr/lib/loginsight/application/3rd_party/apache-tomcat/conf/keystore does not exist.

Environment

Aria Operations for Logs 8.18.x

Cause

md5sum keystore

The keystore file missing from /usr/lib/loginsight/application/3rd_party/apache_tomcat/conf directory.

Resolution

To workaround the issue:

    1. SSH into primary node and worker nodes as root.
    2. Change to the tomcat directory and check for the keystore file.
      • cd /usr/lib/loginsight/application/3rd_party/apache_tomcat/conf
        ls -l keystore*
    3. On the primary node the keystore file will be missing but there is a keystore.bak file.  The worker nodes will have both the keystore and keystore.bak file.
    4. Run a checksum on the keystore.bak on the primary node.
      • md5sum keystore.bak
    5. Run a checksum on the keystore file on the worker nodes.
      • md5sum keystore
    6. If the checksum matches the keystore.bak file on the primary node and the keystore on the worker nodes you can copy the keystore.bak file on the primary node to keystore.
      • cp -p keystore.bak keystore
    7. Restart loginsight services on the primary node.
      • service loginsight restart
    8. Log into the UI from the primary node.