vSAN disk group reconfiguration fails because disks are formatted as VMFS
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Article ID: 415535
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Updated On:
Products
VMware vSAN
Issue/Introduction
When attempting to add disks to an existing disk group in vSAN (via vSAN Cluster > Configure > Disk Management > Select ESXi Host > View Disks > Select Disk Group > Add Disk), the available disks do not appear in the wizard. As a result, the disks cannot be selected or added to the vSAN disk group.
In vSAN Disk Management (vSAN Cluster > Configure > Disk Management > Select ESXi Host > View Disks > Select Disk Group), the disks appear as ineligible, although the disks are listed.
Upon verification from the ESXi host (Host > Configure > Storage Devices > Select LUN), it was found that the LUN is formatted with VMFS.
Environment
VMware vSAN 8.x
Cause
vSAN requires that disks added to a disk group be unformatted and dedicated to vSAN. Upon checking the ESXi host (Host > Configure > Storage Devices > Select LUN), it was found that the target LUN is formatted with VMFS, meaning it is already in use as a datastore.
Because vSAN cannot use disks that contain existing VMFS partitions, the LUN is automatically marked as ineligible in Disk Management. This behavior prevents accidental data loss on disks that are already serving other purposes.
Resolution
Place the ESXi host in Maintenance Mode using the Ensure Accessibility option.
In the vSphere Client, navigate to: Cluster > Hosts > Right-click the affected ESXi host > Maintenance Mode > Enter Maintenance Mode > Ensure Accessibility.
Remove the VMFS Partition from the Device
In the vSphere Client, go to: Host > Configure > Storage Devices > Select the affected LUN > Actions > Clear VMFS/Partition.