Failing to authenticate to vCenter server error after updating the SSO credentials for an on-premise VMware Cloud Director Availability appliance
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Failing to authenticate to vCenter server error after updating the SSO credentials for an on-premise VMware Cloud Director Availability appliance

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Article ID: 415446

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Updated On:

Products

VMware Cloud Director VMware Cloud Director Availability - Disaster Recovery 4.x VMware Cloud Director Availability - Migration 4.x

Issue/Introduction

  • The vCenter lookup service SSO credentials were updated locally on an on-premise VMware Cloud Director Availability appliance.
  • The credentials used are confirmed to be correct and have adequate permission in the underlying vSphere environment.
  • Errors similar to the following are seen in the user interface:

    Failed to authenticate to vCenter server

Environment

VMware Cloud Director Availability 4.7.3.x

Cause

As part of the registration with the provider site, there are details stored between the sites to facilitate and maintain the health of the connection. This local change invalidates this registration and prevents appropriate validation of a healthy configuration.

Resolution

As noted in the following document, the on-premise appliance must be repaired with the provider site after altering the SSO credentials:

Configure after changing the vCenter SSO credentials