Troubleshooting steps for sdgtw probe issues
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Troubleshooting steps for sdgtw probe issues

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Article ID: 415409

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

How to troubleshoot and gather the necessary information, debug info for effective sdgtw troubleshooting.

Environment

  • sdgtw 2.38 or higher
  • DX UIM 23.4 CU4 or higher
  • ServiceNow Yokohama

Cause

  • sdgtw troubleshooting guidance

Resolution

  1. Upgrade sdgtw to the latest GA version

  2. Set sdgtw loglevel to 5 and logsize to 50000 and click ok.

  3. Navigate to: ...\Nimsoft\probes\gateway\sdgtw\NIMSM_WORKSPACE\webapp\WEB-INF\config on the Primary hub or robot under the Primary hub where sdgtw is deployed.

  4. Edit the log4j2.xml file and change this section from ERROR to DEBUG in the file:

    • <logger name="com.ca.integration.normalization.mdr.servicenow" level="DEBUG" additivity="false">
      <AppenderRef ref="LOGFILE"/>
      </logger>
  5. Deactivate sdgtw

  6. Wait until the sdgtw port and PID disappear

  7. Activate sdgtw

  8. Wait about 15 minutes or more and attach the 'Nim.log' under the logs directory from the folder listed below:

      ...\Program Files (x86)\Nimsoft\probes\gateway\sdgtw\NIMSM_WORKSPACE\webapp\WEB-INF\logs

    • Note: Nim is a 'common component' like middleware, that we provide for the integration between UIM and ServiceNow.

  9. Attach the sdgtw.log and _sdgtw.log files as well as the sdgtw.cfg

  10. If the sdgtw issue concerns alarms/alarm sync, attach a copy of a few of the alarms (text)

Additional Information

  • Alternatively, for deeper debugging at a highly verbose level (all levels), you can edit the log4j2.xml and change all of the levels to ALL, e.g., for each logger section:

<Root level="ALL">
<logger name="com.ca.integration.normalization.mdr.ca.nsd" level="ALL" additivity="false">
etc...
etc...

  • But note that every time you deploy sdgtw or upgrade it, the file will revert back to the defaults.

  • Once the logs are fetched with all and troubleshooting is done, and a root cause is found, and fix identified, you can replace the original file and restart the robot which should revert the log4j2.xml file back to the default version.