Error when deleting the vSphere Network resource from the Topology section in the Deployment
search cancel

Error when deleting the vSphere Network resource from the Topology section in the Deployment

book

Article ID: 415400

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • In Service Broker, under Consume > Deployments > Deployments >  Selected Deployment > Topology:
    • You have an existing vSphere backed Network in a certain Deployment which you would like to Delete and remove from the Deployment.
    • Sending a delete API call to the Network resource results in failure with error:
      • DELETE "https://lab.example.com/deployment/api/deployments/########-####-####-####-########/resources/########-####-####-####-########"
      • {
          "message": "No value present",
          "statusCode": 404,
          "errorCode": 0
        }

Environment

  • Aria Automation 8.18.x

Cause

  • There is no delete method available through the UI or API for the call against deployment resources:
    • DELETE "https://lab.example.com/deployment/api/deployments/########-####-####-####-########/resources/########-####-####-####-########"
  • Hence we result in having a 404 response, as the method "DELETE" does not exist for that call, only GET, PUT and PATCH.
    • {
        "message": "No value present",
        "statusCode": 404,
        "errorCode": 0
      }

Resolution

 

  • If this is not possible or desired, we can unregister the VM from Aria Automation and re-onboard it to a new deployment once the Networks are manually unlinked in vSphere:
    • In Service Broker, under Consume > Deployments > Virtual Machines > Managed > Three Dots next to Selected VM  > Unregister
    • The chosen VM will go from "Deployed" to "Discovered" Origin and will be found under the "Discovered" tab rather than "Managed" once the Data Collection completes on the vCenter Cloud Account (10 minute cycle),  since we have removed the VM from Aria Automation management.
    • Make your changes, removing Networks manually from the machine etc. while waiting for this Data Collection cycle to start.
    • Once the Data Collection is completed and the VM is in a "Discovered" state, select the VM using the Checkbox on the left and click "Onboard".
    • Select the type of Onboarding and give the Deployment a name if you wish.
    • Click "Onboard".
    • Once complete the VM should now show in the "Managed" section again.
    • We can go back to our Deployments from above and find the Deployment with the name we just set.
    • We can see the VM onboarded with no additional existing vSphere backed Networks.