vAPP rename error "Error: Access is forbidden"
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vAPP rename error "Error: Access is forbidden"

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Article ID: 415364

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

Attempts to rename a vApp fail with the error “403 Access Forbidden”, appearing both in the UI and API. The on-screen message reads “Error: Access is Forbidden.”

Environment

VMware Cloud Director 10.3

Cause

The default API call for this action should be to rename vapp (vnd.vmware.vcloud.vApp+xml;charset=utf-8) and instead the UI is using the * which is pulling vm rename (? application/*+xml;charset=utf-8 )

This behavior was changed in newer releases to use the appropriate API

Resolution

This issue is resolved in 10.5 and above

Workaround

Manually use an API client and manually edit the 'Content Type' field to use the new Media Type.

Steps:

  1. Create a GET Rest API call to https://<vcd_FQDN>/api/vApp/<vapp-id> (You can get this vapp-id from the ui by highlighting the vapp and looking at the url address bar. The ID will be in format vapp-XXXXXX)
  2. Modify the headers of the request as making sure the Content type in use is               'application/vnd.vmware.vcloud.vApp+xml;charset=utf-8'
  3. Modify the type of command from GET to PUT
  4. Modify the body content, editing the name of the VM
  5. Press SEND
  6. The result should be 200 OKAY