VM not reachable after being added to PortGroup with VLAN Trunking configuration
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VM not reachable after being added to PortGroup with VLAN Trunking configuration

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Article ID: 415343

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • A virtual machine (VM) becomes unreachable (cannot be pinged or accessed) after being connected to a port group configured for VLAN trunking.
  • VLAN trunk portgroup is properly configured to the Virtual Machine port id:
    net-dvs | grep -i <PORT_ID> -A 15 | grep -iE "portid|ranges"
                    com.vmware.common.port.volatile.status = inUse linkUp portID=<PORT_ID>  propType = RUNTIME
                            ranges = <VLANs>

Environment

VMware vSphere ESXi
VMware vCenter Server

Cause

VLAN tagging requires that the virtual network interface card (vNIC) supports the IEEE 802.1Q protocol.
Not all virtual NICs support VLAN tagging, and in some cases, VLAN ID configuration may be disabled or not properly set.

Resolution

The VM should be using the VMXNET3 network adapter type for VLAN trunking and tagging functionality.

To ensure proper VLAN tagging support, verify and configure the VLAN ID on the network adapter for Windows:

  1. Open Device Manager on VM.
  2. Expand Network adapters.
  3. Right-click the affected network interface card (NIC) and select Properties.
  4. Click the Advanced tab.
  5. Scroll down and locate the VLAN ID property.
  6. Set the desired VLAN ID (corresponding to the VLAN assigned on the trunk port group).
  7. Click OK to apply the changes.
    Example:

 

Additional Information

If you are using Linux distributions, firewall appliances, or load balancers, please engage your system or vendor support to confirm the proper method of setting up VLAN IDs within the operating system.