"Exception occurred in postinstallHook for B2B-patching. Please check the logs for more details. Take corrective action and then resume." when attempting to update a VCSA.
search cancel

"Exception occurred in postinstallHook for B2B-patching. Please check the logs for more details. Take corrective action and then resume." when attempting to update a VCSA.

book

Article ID: 415247

calendar_today

Updated On:

Products

VMware vCenter Server VMware vCenter Server 8.0

Issue/Introduction

The error message "Exception occurred in postinstallHook for B2B-patching.  Please check the logs for more details.  Take corrective action and then resume." is displayed in the VAMI of a VCSA when attempting to perform an update.

When reviewing the /etc/vmware/wcp/wcpsvc.yaml configuration file, you see the rhttpproxy_port value set to {rhttpproxy.ext.port2} :

rhttpproxy_port: {rhttpproxy.ext.port2}

Environment

VMware vCenter Server 8.x

Cause

An incorrect entry in the /etc/vmware/wcp/wcpsvc.yaml configuration file will not allow the wcp and other services to start as expected.

Resolution

See KB 326225 (link in the additional information section below) for the steps to resolve this issue.

Additional Information