Unable to preform backups on Rubrik
search cancel

Unable to preform backups on Rubrik

book

Article ID: 415223

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

After deploying a new Rubrik appliance that has multiple subnets and one of the NICs is unable to connect to the host in order to preform a backup on the new distributed port created for this VM 

Environment

VMware vSphere ESXI

 

Cause

Due to misconfigurations on the Rubrik OS on the IP's and also missing VLAN tagging due to which the traffic could not flow

Resolution

Information gathering and troubleshooting from the VMware side  

  • Get  the following data 
    • VM name 
    • Network 
    • New distributed port 
    • Is this Distributed port using a Lag?
    • is this port using a Tag VLAN? 

 This is were we can find most of the data related to lag and Vlan Tagging 

  • Go to network and look at the port in question, either click action and edit setting or right click an edit settings

This is for the VLAN 

And this is for Teaming and failover 

 

Troubleshooting 

  • Open a Putty session to the host that has this virtual machine 
    • ESXTOP ( once in type n for networking)  or also net-stats -I
    • Find which switch port this is using 

pktcap-uw --switchport (Enter Switchport ID) --capture VnicTx,VnicRx --ip (Enter destination ip) -o - | tcpdump-uw -enr-

  • This packet capture will show if there is traffic coming from this particular VM

If we don't see the traffic in the capture, next step would be to contact Rubrik support for further assistance