JBoss directory currently in use. Please shutdown Automation Analytics & Intelligence or any programs/windows that may be using this directory (i.e. currently viewing log files)
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JBoss directory currently in use. Please shutdown Automation Analytics & Intelligence or any programs/windows that may be using this directory (i.e. currently viewing log files)

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Article ID: 415209

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Updated On:

Products

Automation Analytics & Intelligence

Issue/Introduction

When attempting to upgrade AAI, the error below is seen in the <Upgrade Dir>/install/upgrade.log file after the upgrade has failed.

[java] java.lang.Exception: JBoss directory currently in use. Please shutdown Automation Analytics & Intelligence or any programs/windows that may be using this directory (i.e. currently viewing log files)

 

 

Cause

This can be caused by:

  • Not shutting down the AAI service or process
  • Having the AAI configuration tool open when trying to upgrade
  • Having any files within the AAI Installation directory open 
  • Having any open folders on Windows within the AAI directory 

Resolution

  • Shutdown the AAI service and any processes 
  • Ensure there are no log files open
  • Ensure the legacy configuration tool is not open
  • If on Windows close any open folders within the AAI directories