Failed to delete auth source for management Component error after redeploying VCF automation
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Failed to delete auth source for management Component error after redeploying VCF automation

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Article ID: 415171

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Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • VCF Automation has been redeployed.
  • Attempts to remove the pre-existing SSO configuration setup against the initial Automation instance in Fleetmanager fails with:

    Failed to delete auth source for management Component

Environment

  • VCF Automation
  • VCF Operations

Cause

Currently there is no check before deleting AuthSource if it exists. Thats causing the issue as the AuthSource in VCFA is removed as part of redeployment

Resolution

Procedure

IMPORTANT: Ensure that snapshots of Operations nodes are taken before any queries are run against the database.
  1. SSH to the primary VCF Ops appliance.
    NOTE: If SSH is not enabled, you must go to the VCF Ops admin page to enable it: https://<vcfops_fqdn>/admin
  2. Run this command to access the database:
    su - postgres -c "/opt/vmware/vpostgres/current/bin/psql -p 5433 -d vcopsdb"
  3. Check if the VCFA record is present:
    SELECT * FROM kv_vidb_auth_sources WHERE vcf_component_type = 'VCF_AUTOMATION';
  4. Clean the VCF Automation record by running this command:
    DELETE FROM kv_vidb_auth_sources WHERE vcf_component_type = 'VCF_AUTOMATION';
  5. Check that the VCFA record is no longer present:
    SELECT * FROM kv_vidb_auth_sources WHERE vcf_component_type = 'VCF_AUTOMATION';
  6. Exit from the database:
    exit

You may now configure the SSO for the new Automation instance by following the steps contained in the following documentation.