ULM agent installation fails. 2147484148, Unknown error
search cancel

ULM agent installation fails. 2147484148, Unknown error

book

Article ID: 415138

calendar_today

Updated On:

Products

IT Management Suite

Issue/Introduction

Pull method of ULM installation fails with unknown error

 

[root@client ~]# chmod u+x aex-bootstrap
[root@client ~]# ./aex-bootstrap
Verifying archive integrity... All good.
Uncompressing Symantec Management Agent Installer 8.8.1123
......
INFO: The configuration XML file not found at: '/root/.aex-agent-install-config.xml'
INFO: Trying to extract embedded install XML from bootstrap file.
INFO: Installation directory created: /opt/altiris/notification/nsagent.
NOTE: Extracted Install XML to the file: /opt/altiris/notification/nsagent/.aex-agent-install-config.xml.
WARNING: Could not find NS version header in response for URL: http:/ServerName/Altiris/NS/Agent/ConnectionTest.asp.
WARNING: Failed to establish connection with 'http://ServerName/Altiris/NS/Agent/ConnectionTest.asp' (2147484148, Unknown error).
ERROR: Failed due to previous warnings or errors. See log above.
Please ensure you provide either install XML in current working directory,
or run correct bootstrap file with embedded install XML,
or specify NS/URL parameter.
In case of HTTPS the certificate should be in XML file.

Environment

any

Cause

Error caused by 503 error during client request on server side.

In this case Symantec Agent AppPool application pool is stopped

To verify server output you may use following method:

[root@client ~]# curl -k http://ServerName/Altiris/NS/Agent/ConnectionTest.asp
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""http://www.w3.org/TR/html4/strict.dtd">
<HTML><HEAD><TITLE>Service Unavailable</TITLE>
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Service Unavailable</h2>
<hr><p>HTTP Error 503. The service is unavailable.</p>
</BODY></HTML>

Resolution

Resolve 503 error on server side. (Starting application pool in this scenario)