Failed vCenter Update vCenter 8.0.3.xx to 8.0.3.xx : "Installation failed. Please collect the VC support bundle."
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Failed vCenter Update vCenter 8.0.3.xx to 8.0.3.xx : "Installation failed. Please collect the VC support bundle."

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Article ID: 415133

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Patch Update Install Fails from VAMI as well as vCenter CLi

[2025-10-19 09:35:57,143] : Installing version: 8.0.3.00600
[2025-10-19 09:36:01,662] : Installation failed. Please collect the VC support bundle.

 

/var/log/vmware/applmgmt/patchRunner.log

         "name": "vmdir",
        "patchScript": "/storage/seat/software-updatedvsay6u1/stage/scripts/patches/payload/components-script/vmdir",
        "requirementsResult": {
            "mismatches": [
                {
                    "description": {
                        "id": "vmdir.replicationerror.text",
                        "localized": "VMDir replication is not working correctly",
                        "translatable": "VMDir replication is not working correctly"
                    },
                    "problemId": null,
                    "relatedUserDataId": null,
                    "resolution": {
                        "id": "vmdir.replicationerror.resolution",
                        "localized": "Please refer the KB to handle VMDir replication issues: https://kb.vmware.com/s/article/93910",
                        "translatable": "Please refer the KB to handle VMDir replication issues: https://kb.vmware.com/s/article/93910"
                    },
                    "severity": "error",
                    "text": {
                        "id": "vmdir.replicationerror.text",
                        "localized": "VMDir replication is not working correctly",
                        "translatable": "VMDir replication is not working correctly"
                    }
                }
				
				
                "requiredDiskSpace": {}
            }
        },
        "stageDir": "/storage/seat/software-updatedvsay6u1/stage/patch_runner/cis-license"
    }
]

2025-10-19T11:14:42.995Z INFO rpm_utils Validating if ['VMware-vsan-racadm'] rpms can be removed from the system.
2025-10-19T11:14:43.9Z INFO vmware_b2b.patching.phases.discoverer Check if there is enough storage for RPM installation
2025-10-19T11:14:43.9Z INFO vmware_b2b.patching.phases.discoverer RPM stage dir is /storage/seat/software-updatedvsay6u1/stage/patch_runner/../../../stage/stageDir.json
2025-10-19T11:14:43.10Z ERROR __main__ Discovery of vCSA patching components failed
(END)

Environment

vCenter 8.x

Cause

vCenter is standalone, but if it was under ELM in the past.

The replication agreements were not removed completely, and the stale entries remained in the vCenter.

Run the command to identify: # /usr/lib/vmware-vmdir/bin/vdcrepadmin -f showpartnerstatus -h localhost -u Administrator

 

root@VC1 [ ~ ]# /usr/lib/vmware-vmdir/bin/vdcrepadmin -f showpartnerstatus -h localhost -u Administrator
password:
Partner: VC2.domain.com
Host available:   Yes
Status available: Yes
My last change number:             1752497
Partner has seen my change number: 1383370
Partner is 369127 changes behind.


----------------


root@VC2 [ ~ ]# /usr/lib/vmware-vmdir/bin/vdcrepadmin -f showpartnerstatus -h localhost -u Administrator
password:
Partner: VC1.domain.com
Host available:   Yes
Status available: Yes
My last change number:             1556148
Partner has seen my change number: 1479071
Partner is 77077 changes behind.

Resolution

If we can still see the replication agreement on the the vCenter, it mean that the vCenter has not been properly decommissioned, so we should unregister the Stale vCenter registry first using the cmsso-utils

1. Take powered-off Snapshots of all the vCenters either in the ELM or standalone

2. Run the below command to unregister stale vCenter.

# cmsso-util unregister --node-pnid vCenterServer_System_Name --username administrator@your_domain_name --passwd 'vCenter_Single_Sign_On_password'

Where vCenter_Server_Appliance_System_Name is the FQDN or IP address of the vCenter Server Appliance that you want to decommission. Please enter the vCenter_Single_Sign_On_password in quotes. Please read this KB, https://knowledge.broadcom.com/external/article/316470

 

If the cmsso-utils is not removing completely, follow the Workaround below to manually delete the Entry:

•   Take powered-off Snapshots of all the vCenters either in the ELM or standalone, remove the replication agreements using the below command, and Reboot the vcenter.

* Determining replication agreements and status with the Platform Services Controller (PSC)
https://knowledge.broadcom.com/external/article/316504/determining-replication-agreements-and-s.html

# ./vdcrepadmin -f removeagreement -2 -h Source_PSC_FQDN -H PSC_FQDN_to_Remove_from_Replication -u administrator -w Administrator_Password

•   Manually Unstage the Update, Re-stage the update from VAMI, and Install Update

  1. Log in to your vCenter Appliance via SSH.
  2. Run following command:
software-packages unstage
  1. Start the update process again.
The alternative way to Unstage on Cli: 
# service-control --stop applmgmt
# rm -rf /storage/core/software-update/updates/*
# rm -rf /storage/core/software-update/stage/*
# rm -rf /storage/db/patching.db
# mv /storage/core/software-packages/staged-configuration.json /storage/core
# mv /etc/applmgmt/appliance/software_update_state.conf /storage/core
# service-control --start applmgmt

As confirmed by VMware Engineering team, this command also can be helpful in some scenarios, if it uses /storage/seat partition to store the software-update:
# rm -rf /storage/seat/software-*

Additional Information

* Update of vCenter fails with "Stage path file doesn't exist" or "Package discrepency error, Cannot resume!"
https://knowledge.broadcom.com/external/article?articleNumber=318581