After upgrading from UsageMeter 4.8 to 9.0.1.0, you cannot connect to the web interface.
search cancel

After upgrading from UsageMeter 4.8 to 9.0.1.0, you cannot connect to the web interface.

book

Article ID: 415097

calendar_today

Updated On:

Products

VMware Usage Meter

Issue/Introduction

  • After upgrading from UsageMeter 4.8 to 9.0.1.0, you cannot connect to the web interface.
  • When checked with status.sh, vmware-um-gw.service is in the activating state.

    root@umname [ /opt/vmware/var/log ]# systemctl status vmware-um-gw.service
    ● vmware-um-gw.service - VMware Cloud Foundation Usage Meter Gateway Service (NGINX)
         Loaded: loaded (/usr/lib/systemd/system/vmware-um-gw.service; enabled; preset: enabled)
         Active: activating (auto-restart) (Result: watchdog) since Fri yyyy-mm-dd hh:mm:ss UTC; 762ms ago
        Process: 14410 ExecStartPre=/bin/bash -c sudo /opt/vmware/cloudusagemetering/scripts/sync-certificates.sh && /opt/vmware/cloudusagem>
        Process: 14507 ExecStart=/opt/vmware/cloudusagemetering/scripts/nginx.sh (code=dumped, signal=ABRT)
        Process: 14585 ExecStopPost=/opt/vmware/cloudusagemetering/platform/bin/notify-restart.sh vmware-um-gw.service (code=exited, status=>
       Main PID: 14507 (code=dumped, signal=ABRT)
            CPU: 5.194s

    MM DD hh:mm:ss umname systemd[1]: vmware-um-gw.service: Failed with result 'watchdog'.

Environment

VCF Usage Meter 9.0

Cause

This issue occurs when iptables.service is stopped.

Resolution

Manually start the iptables.service and verify that the issue is resolved.

1.  Use the following command to check if the iptables service is active:
systemctl status iptables.service

2.  Confirm that service is not active in step 1, use the following command to start the iptables service:
systemctl start iptables.service

3.  Verify that the vmware-um-gw service is active and the issue is resolved.