Cluster shows Not Active
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Cluster shows Not Active

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Article ID: 414947

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Updated On:

Products

VMware Telco Cloud Automation

Issue/Introduction

After performing an upgrade of TCA through the Tanzu CLI. The workload cluster in TCA shows "Not Active"

Environment

2.3

Cause

Performing an upgrade outside of the TCA web portal is not supported and may create inconsistencies in the TCA Manager and TCA CP PostgreSQL database

Resolution

  1. Obtain the cluster ID.
    PGPASSWORD="$(cat /common/pgsql/passwords/tca_admin)" psql -U tca_admin -d tca -c "SELECT name, id, status, \"rowType\" FROM \"K8sClusterDetails\" ORDER BY \"createdAt\" DESC;" > /tmp/pg_query.txt
    


  2. Verify the cluster in the TCA Manager PostgreSQL database.
    PGPASSWORD="$(cat /common/pgsql/passwords/tca_admin)" psql -U tca_admin -d tca -c "SELECT * FROM \"K8sClusterDetails\" WHERE val->>'id'='########-####-####-####-############' AND val->>'rowType'='cluster';" > /tmp/pg._query.txt
    
  3. Update val.status to "Active" in the TCA Manager PostgreSQL database
    PGPASSWORD="$(cat /common/pgsql/passwords/tca_admin)" psql -U tca_admin -d tca -c "UPDATE \"K8sClusterDetails\" SET val = jsonb_set(val, '{status}', '\"ACTIVE\"', false) WHERE val->>'id'='########-####-####-####-############' AND val->>'rowType'='cluster';"