Error: "Unable to retrieve status for segment port " in NSX Manager
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Error: "Unable to retrieve status for segment port " in NSX Manager

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Article ID: 414944

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Updated On:

Products

VMware NSX

Issue/Introduction

  • You see the following messages at /var/log/syslog of NSX Manager
<timestamp> <hostname> NSX 5205 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM500016" level="ERROR" subcomp="manager"] Unable to retrieve status for segment port /infra/segments/<Logical-Switch-UUID>/ports/default:<Logical-Port-UUID> from enforcement point /infra/sites/default/enforcement-points/default with following exception
  • According to envoy_access_log.txt, an external device is executing an API to retrieve information about a non-existent Logical Port.
[<timestamp>] ###.###.###.### ###.###.###.### "GET" "/policy/api/v1/infra/segments/<Logical-Switch-UUID>/ports/default:<Logical-Port-UUID>/status?enforcement_point_path=%2Finfra%2Fsites%2Fdefault%2Fenforcement-points%2Fdefault" "HTTP/1.1" 404 - 0 ### ### ### "###.###.###.###" "Apache-HttpClient/4.5.9 (Java/17.0.10)" "<UUID>" "###.###.###.###:###" "###.###.###.###:###"
  • The Logical-Port-UUID for a non-existent logical port is displayed in logs.

Environment

VMware NSX

 

Cause

An error occurred because of trying to retrieve information about a non-existent logical port.

Resolution

To stop this error, investigate the reason for executing the API on the requesting device.