Unable to select the "I agree to the Terms and Conditions" checkbox when attempting to access an NSX 4.x upgrade bundle.
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Article ID: 414927
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Updated On:
Products
VMware NSX
Issue/Introduction
The customer is needing to upgrade his NSX release to a newer version of 4.x.
Within the support.broadcom.com NSX download page, there is a "checkbox" present right next to: "I agree to the Terms and Conditions". This must be clicked to confirm that the user agrees to the terms and conditions, after which the user will be permitted to download the NSX upgrade package.
You find that hovering your pointer over the "checkbox" and clicking the mouse's left-click button does not achieve your goal of selecting or "checking" the box. Attempts to use the keyboard enter key to check the box fail as well.
Environment
VMware NSX
Cause
This is the expected behavior.
Many products, software included, must ensure that a customer uses said products as they are intended to be used.
It is desired that all customers be knowledgeable as to what they are agreeing to when clicking on the "Terms and Conditions" checkbox, so forcing them to bring this information onto their monitor (and hopefully reading it) makes it easier for us to accomplish this goal.
Resolution
Part of the "I agree to the Terms and Conditions" text is capitalized, as well as colored in blue: "Terms and Conditions". This needs to be clicked, which ends up bringing the user to a new page where the terms and conditions for being permitted to download the NSX upgrade OVA are defined.
After viewing the "Terms and Conditions" page and then navigating back to the page where the ova download is located, you will then be able to click the checkbox, if you do in fact agree to the terms and conditions as defined in the documentation.