NetApp NFS -- After completing NetApp NA lif migration the VMs became unresponsive (= inaccessible)
search cancel

NetApp NFS -- After completing NetApp NA lif migration the VMs became unresponsive (= inaccessible)

book

Article ID: 414919

calendar_today

Updated On:

Products

VMware vSphere ESXi VMware vSphere ESX 8.x VMware vSphere ESXi 8.0

Issue/Introduction

Potential scenarios:
  • A new NFS Share was connected to ESXi Hosts
  • New Storage Heads and Disks were purchased and NFS Storage lifs were migrated over to the new Heads
 
Unfortunately when attempting to operate VMs on it, VMs become randomly inaccessible (= unresponsive).
 
 
In the var/log/vobd.log of one of the Hosts connected to this Datastore, you observe that the connection to the new NFS Datastore is lost randomly:
 
YYYY-MM-DDTHH:MM:SS.XXXZ In(14) vobd[2097765]:  The event ([esx.problem.storage.apd.start] Device or filesystem with identifier [11111111-1111111] has entered the All Paths Down state.) was sent immediately to hostd;
YYYY-MM-DDTHH:MM:SS.XXXZ In(14) vobd[2097765]:  [vmfsCorrelator] 282143000255us: [vob.vmfs.nfs.server.disconnect] Lost connection to the server ###.##.##.## mount point /YourDatastoreName, mounted as 11111111-1111111-0000-000000000000 ("YourDatastoreName")


Environment

ESXi 8.x

Cause

Connection issue caused by underlying MTU misconfig.

Example: NetApp Network uplink does not hav Jumbo Frames enabled.

Resolution

Check the MTU configuration by conducting vmkping tests by reviewing the following documentation: 

NFS datastore is inaccessible on all the ESXi

Testing VMkernel network connectivity with the vmkping command