vCenter server upgrade stuck at 0% in stage 1
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vCenter server upgrade stuck at 0% in stage 1

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Article ID: 414894

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • During the vCenter Server upgrade, Stage 1 does not progress beyond 0% and no error is displayed.

  • The vCenter Installer logs, C:\Users\<UserName>\AppData\Local\Temp\vcsaUiInstaller\installer-* will not write anything past the below entries,

[YYYY-MM-DDTHH:MM:SS] - info: --prop:guestinfo.cis.vpxd.ha.management.addr=<vCenter FQDN>
[YYYY-MM-DDTHH:MM:SS] - info: --prop:guestinfo.cis.vpxd.ha.management.port=443
[YYYY-MM-DDTHH:MM:SS] - info: --prop:guestinfo.cis.vpxd.ha.management.user=<[email protected]>
[YYYY-MM-DDTHH:MM:SS] - debug: ovaFile retrieved: <Path if the ISO>
[YYYY-MM-DDTHH:MM:SS] - debug: ovftoolCmd retrieved: <Path if the ISO>
[YYYY-MM-DDTHH:MM:SS] - debug: Updated current session with lstActTm <Timestamp of the upgrade>

 

Environment

VMware vCenter Server 8.x

Cause

The upgrade process is blocked by firewall or antivirus software on the Windows client used to run the vCenter Installer. These security controls prevent required outbound communication to the vCenter Server or ESXi hosts over TCP port 443, causing Stage 1 to remain stuck.

Resolution

  1. Ensure that ports 443 is open for communication between the Client Machine and target appliances, as well as the vCenter managing the source appliance.
  2. Run the following commands from the client machine to verify port connectivity:
    • Using Command Prompt:
      • netstat -ano | find /i "443"
    • Using PowerShell:
      • Test-NetConnection <vCenter/ESXi FQDN or IP> -Port 443
  3. If the ports are not reachable, engage the Internal network or security team to review firewall and antivirus policies.
  4. Validate that all vCenter upgrade network prerequisites are met as per the Broadcom documentation.