Host connection failure with vCenter
search cancel

Host connection failure with vCenter

book

Article ID: 414880

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Error seen in syslog.all:

ConfigStore[8217073]: Using VMware ESXi syslog APIs
ucs-tool-esxi-cfg : INFO     : Missing ucs_tool_last_config.yaml on host
ucs-tool-esxi-cfg : INFO     : Hash is different, applying the network config
ucs-tool-esxi-cfg : INFO     : Running command: /opt/ucs_tool_esxi/ucs_ipmitool read_file host-cfg.yaml /opt/ucs_tool_esxi/host-cfg.yaml
ucs-tool-esxi-cfg : INFO     : Not configuring network, port group specified in annotation doesn't exist.
trx-init[8217534]: trx-init TRX is not running

Environment

7.0.3, 7.0U3n

Cisco UCS

Cause

  • The Cisco UCS tool is detecting config drift after host disconnection or network changes
  • Unable to apply network config because the expected port group is absent.
  • vCenter/Cisco UCS network consistency and ESXi host network state not synchronized.

Resolution

Environmental issue. Need to review with network/UCS tool team:

  • Verify port groups in vCenter and CiscoUCS. If port group is missing, recreate the port group with the correct name.
  • Reconcile fabric profiles if there have been any recent fabric/UCS profile changes.
  • Recreate missing port groups
  • Reapply or refresh the Cisco UCS networking config on the host.
  • Restart the Cisco UCS tool or ESXi networking services.
  • Ensure host re-registration completes successfully