AlarmNotifier not sending email notifications because message variables are wrongly populated
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AlarmNotifier not sending email notifications because message variables are wrongly populated

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Article ID: 414862

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Updated On:

Products

Network Observability Spectrum

Issue/Introduction

The NotificationData variable value is missing on the non-working device. That is the main reason the email is not sent by the AlarmNotifier.

The problem occurs for some UPS Agent models. The model was already destroyed and recreated, but the problem persists.

New onboarded UPS Agents have the same issue.

Snip from NOTIFIER.OUT of the non-working device:

Alarm SET:

Date:             10/07/2025
Time:             13:34:06
DeviceType:       10/07/2025
Mtype:            UniPowerSageONDev
ModelName:        UPS Agent
AlarmID:        
Severity:       
ProbableCauseID:
RepairPerson:   
AlarmStatus:     
SpectroSERVER:    10/07/2025
Landscape:        13:34:06
ModelHandle:      UniPowerSageONDev
ModelTypeHandle:  UPS Agent
IPAddress:      

Snip from NOTIFIER.OUT of the working device:

Alarm SET:

Date:             10/07/2025
Time:             13:36:37
DeviceType:       ComexCore3K
Mtype:            UniPowerSageONDev
ModelName:        UPS Agent
AlarmID:          28295483
Severity:         CRITICAL
ProbableCauseID:  fff00004
RepairPerson:   
AlarmStatus:     
SpectroSERVER:    <SS hostname>
Landscape:        0x1000000
ModelHandle:      0x105f30f
ModelTypeHandle:  0x70b0000
IPAddress:        <IP Address>

SecurityString:   SEVERI
AlarState:        NEW
Acknowledged:     FALSE
UserClearable:    FALSE
Location:
AlarmAge:         0

NotificationData: <destination_email_address>

Environment

 DX NetOps Spectrum Windows platform

Cause

There are hexadecimal values in the SysContactSysName and SysLocation OIDs in the non-working device, rather than regular string values.

  • 1.3.6.1.2.1.1.4.0 - SysContact
  • 1.3.6.1.2.1.1.5.0 - SysName
  • 1.3.6.1.2.1.1.6.0 - SysLocation

 

Sapwalk2 output of the non-working UPS device:

spectrum@<SS_host> /c/win32app/Spectrum/bin
./sapwalk2.exe -i <IP Address> -v v2c -c <SNMP Community> -s 1.3.6.1.2.1.1.3.0 -w 1.3.6.1.2.1.1.6.0
#sapwalk2: ver 25.0
#Copyright (c) 1994-2021 SIMPLESOFT Inc.
#Address=<IP Address>, StartOid=1.3.6.1.2.1.1.3.0
#TimeOut=90000, MaxRetries=3, CompareFlag=0
#args: -i <IP Address> -v v2c -c xxxxx  -s 1.3.6.1.2.1.1.3.0 -w 1.3.6.1.2.1.1.6.0
1.3.6.1.2.1.1.4.0             , OctetString , 0x41646d696e6973747261746f720a
1.3.6.1.2.1.1.5.0             , OctetString , 0x555053204167656e740a
1.3.6.1.2.1.1.6.0             , OctetString , 0x4d79204f66666963650a
#STATUS: Walk ended as end_of_walk_oid[1.3.6.1.2.1.1.6.0] reached.

 

Sapwalk2 output of the working UPS device:

spectrum@<SS_host> /c/win32app/Spectrum/bin
./sapwalk2.exe -i <IP Address> -v v2c -c <SNMP Community> -s 1.3.6.1.2.1.1.3.0 -w 1.3.6.1.2.1.1.6.0
#sapwalk2: ver 25.0
#Copyright (c) 1994-2021 SIMPLESOFT Inc.
#Address=<IP Address>, StartOid=1.3.6.1.2.1.1.3.0
#TimeOut=90000, MaxRetries=3, CompareFlag=0
#args: -i <IP Address> -v v2c -c xxxxx -s 1.3.6.1.2.1.1.3.0 -w 1.3.6.1.2.1.1.6.0
1.3.6.1.2.1.1.4.0             , OctetString , Administrator
1.3.6.1.2.1.1.5.0             , OctetString , UPS Agent
1.3.6.1.2.1.1.6.0             , OctetString , My Office
#STATUS: Walk ended as end_of_walk_oid[1.3.6.1.2.1.1.6.0] reached.

Resolution

Engage the UPS devices' administrator to change from hexadecimal to a regular string. Then right-click on the non-working device, select Reconfiguration → Reconfigure Model. This will update the updated MIB values on the non-working device in Spectrum.

If the SNMP Community String for the UPS devices is read/write, update the SysContact, SysName and SysLocation OIDs using the OneClick Console.

Move the SysContact, SysName and SysLocation to the right hand side of the Attributes TAB, click on the Edit button, uncheck the "No Change" checkbox and click on OK button to submit the change.

The result is Success if SNMP Community is read/write privilege on the device. Click on the Close button.

Run the sapwalk2 to confirm the change on the device side.

Then right-click on the non-working device, select Reconfiguration → Reconfigure Model. This will refresh the updated MIB values on the non-working device in Spectrum.

Additional Information

This issue does not occur Spectrum in Linux platform.