vMotion is not working, vMotion switch losing connection
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vMotion is not working, vMotion switch losing connection

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Article ID: 414860

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • Multiple VMkernel adapters are used
  • A separate VMkernel adapter is used for vMotion
  • vMotion interface IP does not respond to ping
  • Ping will work if the virtual switch or VMkernel adapter is removed and re-created
  • A VMkernel adapter is on the same subnet or VLAN as the Management VMkernel adapter

Environment

  • VMware vSphere ESXi 7.X
  • VMware vSphere ESXi 8.X

Cause

When multiple VMkernel interfaces on an ESXi host exist in the same network subnet, the host will select only one VMkernel interface to use for communication within this network. This selection process is based on which VMkernel port was created first and configured with an IP address within the subnet. Any subsequently created VMkernel ports in this subnet will not be added to the host's routing table.  This results in an inability to ping the vMotion VMkernel adapter.

It is best practice to have only one VMkernel port configured for each network or VLAN.

Resolution

The best resolution is to provide a separate subnet or VLAN for vMotion.  Follow the VMware vMotion Recommendations section from the Performance Best Practices for VMware vSphere 8.0 guide. 

Additional recommendations and guidance on creating the VMkernel port is found in vMotion interface - Creating a VMkernel port and enabling vMotion on an ESXi host

If only one subnet can be used: