Replace failed vSAN cache disk
search cancel

Replace failed vSAN cache disk

book

Article ID: 414843

calendar_today

Updated On:

Products

VMware vSAN

Issue/Introduction

vSAN cache SSD failed and was replaced, now the old cache SSD is greyed out and cannot be removed

Environment

vSAN (any version)

failed cache SSD

Cause

Cache SSD failure
Physical disk was replaced without being removed from vSAN disk management

Resolution

To remove the old disk group:

  • Go to hosts & clusters view in vCenter, then select the vSAN cluster in question and move to the 'Configure' tab
  • On the 'Configure' tab, under vSAN, select 'Disk Management'
  • Select the disk group and click Remove

To recreate the diskgroup using the new cache SSD:

  • From the 'Disk Management' page, click 'Claim Unused disks'
  • Follow the wizard to create a disk group using the new cache SSD and the previous capacity disks

Additional Information