Network connection with IPv6 between client and AVI Service Engine is unavailable
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Network connection with IPv6 between client and AVI Service Engine is unavailable

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Article ID: 414741

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Updated On:

Products

VMware NSX

Issue/Introduction

  • Client and AVI Service Engine are located on separate IPv6 networks.
  • NSX T1 gateway facilitates traffic routing between AVI Service Engine and client.
  • The TCP dump shows that T1 gateway sent a Neighbor Solicitation to AVI SE, but AVI SE did not receive it.

    07:54:45.082271    <T1 IPV6 adrress>    <T1 IPV6 Request address>    ICMPv6    86    Neighbor Solicitation for <AVI SE address> from <mac address>

  • The command 'get logical-switch XXXX nd-table' shows that there is no ARP entry for the AVI Service Engine.

Environment

VMware NSX 4.X

Cause

T1 gateway is unable to correctly resolve ARP entries for its IP address.

Resolution

Workaround
To enable proper ARP operation on the T1 gateway, refresh its IP address. IPv6 addresses on the segment cannot be removed directly.
To refresh the T1 gateway’s IP address, perform the following steps:

1. Add an IPv4 address.
    a. In NSX Manager, go to 'Networking' -> 'Segments'.
    b. Click 'Edit Segment'.
    c. In 'Gateway CIDR IPv4' field, enter a temporary IPv4 address.
    d. Click 'CLOSE EDITING' to save configuration.

2. Remove the existing IPv6 address.
    a. In NSX Manager, go to 'Networking' -> 'Segments'.
    b. Click 'Edit Segment'.
    c. Remove the existing IPv6 address in 'Gateway CIDR IPv6' field.
    d. Click 'CLOSE EDITING' to save configuration.

3. Re-add the IPv6 address.
    a. In NSX Manager, go to 'Networking' -> 'Segments'.
    b. Click 'Edit Segment'.
    c. In the 'Gateway CIDR IPv4' field, re-enter original IPv6 address.
    d. Click 'CLOSE EDITING' to save configuration.