Error: LCMVROPSYSTEM30018 while deploying VCF Automation 9.x using VCF Ops 9.x
search cancel

Error: LCMVROPSYSTEM30018 while deploying VCF Automation 9.x using VCF Ops 9.x

book

Article ID: 414718

calendar_today

Updated On:

Products

VCF Automation

Issue/Introduction

During new deployment of VCF Automation 9.x using VCF Ops 9.x fails with Error code LCMVROPSYSTEM30018

Error Code: LCMVROPSYSTEM30018
LCMVROPSYSTEM30018
error getting json from object Response{statusCode=400, responseMessage='400', responseData='{"error_message_key":"method.argument.not.valid","error_arguments":["capabilities[1].secret.username : must not be null"],"error_message":"Method argument is not valid."}', responseDataBytes=[#########################################], Server=[Apache], X-Content-Type-Options=[nosniff], Connection=[Upgrade, close], Upgrade=[h2,h2c], Date=[############], X-Frame-Options=[SAMEORIGIN], X-VSCM-Request-Id=[#####], Strict-Transport-Security=[max-age=#####; includeSubDomains], Content-Security-Policy=[default-src https: wss: data: 'unsafe-inline' 'unsafe-eval'; child-src *; worker-src 'self' blob:], X-XSS-Protection=[1; mode=block], Content-Length=[####], Content-Type=[application/json;charset=UTF-8]}}

 

Note: The Error Code: LCMVROPSYSTEM30018 can also be triggered while running an Inventory Sync task for VCF Automation appliance.

Environment

  • VCF Automation 9.x

Cause

Following payload of VCF Ops for VCF logs component had 'null' value for the username and secret Service account confirming deletion of service account caused due to one of the old unsuccessful VCF Logs deployment deletion task leaving VCF Ops in an inconsistent state.
 {
    "key" : "ops-li",
    "type" : "VCF_OPS_LI",
    "name" : "VCF OPS LI",
    "nodes" : [ {
      "name" : "VCF OPS LI_vrli-master",
      "addresses" : [ {
        "type" : "Fqdn",
        "value" : "###########"
      }, {
        "type" : "IPv4",
        "value" : "######"
      } ],
      "certificates" : [ "-----BEGIN CERTIFICATE-----\n######\n-----END CERTIFICATE-----\n" ]
    } ],
    "secret" : JXJXJXJX"type" : "Credential",
      "username" : null,
      "password" : null
    }
  },

Resolution

Ensure there are no failed deletion tasks in the VCF Ops 9.x, if there is, please retry deletion task, and in case of task failing again, please open a new case with Broadcom support team.
In case of old deletion task is successful, please retry VCF Automation 9.x deployment.

Additionally, if the Error Code: LCMVROPSYSTEM30018 is tiggered while running Inventory Sync for VCF Automation (after deployment) then ensure that there is no corrupted component in Fleet Manager. If there is any corrupted component for instance VCF Networks, then resolve the issue with the affected component first and then tigger Inventory Sync for VCF Automation.