VMware Kubernetes Service (VKS) version 3.4 is not listed in the VKS upgrade page, in vCenter version 8.0u3g
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Article ID: 414679
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Updated On:
Products
Tanzu Kubernetes Runtime
Issue/Introduction
When attempting to upgrade the VMware Kubernetes Service (VKS), also known as Tanzu Kubernetes Grid (TKG) Service, to version 3.4 on a vCenter Server instance running version 8.0u3g, the desired VKS version 3.4 does not appear as an option in the dropdown list within the vCenter UI. This occurs in the Supervisor Management > Services section, preventing the upgrade from being initiated through the standard UI method, as shown below.
Environment
VMware Kubernetes Service
Cause
This behavior is by design and results from VKS 3.4 being an asynchronous release. The VKS version options that appear by default in vCenter are those that are embedded with the specific vCenter build (i.e., synchronous releases). An asynchronous release, such as VKS 3.4, is not bundled directly with vCenter Server 8.0u3g. For asynchronous upgrades to newer versions, a manual registration step is now required to make the service available in vCenter.
Resolution
To resolve the issue and make VKS 3.4 available for upgrade, manually register the new version with vCenter.