Aria Operations Cloud Proxy for Log Forwarding is not working
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Aria Operations Cloud Proxy for Log Forwarding is not working

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Article ID: 414671

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Updated On:

Products

VCF Operations VMware Aria Operations (formerly vRealize Operations) 8.x

Issue/Introduction

  • Cloud Proxy has been deployed successfully and shows Online in the Aria Operations UI with both data persistence and log forwarding enabled
  • No logs from the cloud proxy appear in either the Operations server nor the integrated Aria Operations for Logs server
  • Curl connection test from the Cloud Proxy VM to Aria Operations for Logs is successfully over port 9543

curl -v telnet://<vrli-ip>:9543

  • Running docker exec -it vcf-log-forwarder sh -c "curl -k -X POST -H 'Content-Type: application-json' -d '[{\"text\": 123456789}]' https://host.docker.internal:443/vrli/api/v2/events" on the Cloud Proxy VM fails with error "No server is available to service the request."

  • The /data1/vcf-log-forwarder/log-forwarder.log on the Cloud Proxy VM shows

2025-10-12 15:57:53 [I/O Dispatcher 3] ERROR c.v.l.f.p. PostToEndPointProcessor:211 - post to end point failed, with endpointIdentifier=syslog-to-endpoint, url=https://host.docker.internal:443/vrli/api/v2/events, response-code=503, response=<html><body><h1>503 Service Unavailable</h1>No server is available to hand this request.</body></html>

  • The /var/log/httpd-north/error_log shows the following errors on the Cloud Proxy VM

[Sun Oct 12 17:19:10.817027 2025] [ssl:warn] [pid 3548:tid 3548] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Sun Oct 12 17:19:11.389902 2025] [ssl:warn] [pid 3997:tid 3997] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name

 

Environment

Aria Operations 8.18.x

Cause

This issue occurs due to the Cloud Proxy trust store not having the proper root/intermediate CAs in the trust store for the SSL certificate which is installed on Aria Operations for Logs

Resolution

To resolve this issue follow the steps below

  1. From the vCenter Server Web interface, perform a guest shut down on the Cloud Proxy VM.
  2. From the vCenter Server Web interface select the Cloud Proxy VM and click the Configure tab on the right.
  3. Navigate to vApp Options >> Properties.
  4. Under cprc_ca.default value, press Set Value and paste the root CA certificate (in base 64 format) which issued the Aria Operations for Logs SSL certificate
  5. If you have an intermediate certificate in the certificate chain then press Add, then set Key class ID to cprc_ca and set Category to Network Proxy Settings.
  6. Insert the intermediate CA content (in base 64 format) in the Default value field and click Save.
  7. Power on the Cloud Proxy VM.