Infrastructure sync DOWN in SSP due to GMLE leadership safety-violation
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Infrastructure sync DOWN in SSP due to GMLE leadership safety-violation

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Article ID: 414655

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

Problem: After NSX onboarding to SSP or during SSP upgrade, proton restarts continuously.

Symptom: Infrastructure Sync on SSP UI -> NSX Managers shows DOWN.

Proton service restarts continuously. Stale threads of processes related to common agent running.

Environment

SSP 5.1 with either NSX Manager 4.2.x or NSX Manager 9.0 onboarded.

Cause

This is because common agent was not stopping existing threads on a restart. Also, common agent failed to ack lease-loss within GMLE timeout period. 

/var/log/proton/proton_restart.log

2025-07-23T02:42:26.787Z INFO application-restartor restartor 1269613 - [nsx@4413 comp="nsx-manager" level="INFO" subcomp="manager"] ===== APPLICATION IS GOING RESTART (GMLE leadership safety violation handler triggered for groupType: mp) =====

/var/log/proton/nsxapi.log

2025-07-24T00:20:26.269Z INFO GmleClientNonBlockingOpsThread-3 WaitingForLeadershipLostAckState 2609493 - [nsx@4413 comp="nsx-manager" level="INFO" s2comp="wait-leadership-lost-ack" subcomp="manager"] Lease loss acknowledgement has not been received in WaitingForLeadershipLostAckState for lease id 6ccac926-97aa-413a-954e-cb7efce32f7d service COMMON_AGENT_SERVICE on member e5c30242-f3ae-1307-41cf-780a45e15ccd of group 1f2dfa56-7dcf-3583-bedd-f7aec167fec7.

Resolution

Step 1. Identify the NSX Manager node that is the leader for COMMON_AGENT_SERVICE:

su admin -c "get cluster status verbose" | grep COMMON_AGENT_SERVICE

Step 2. Get the IP address of the manager using the UUID from the above output:

su admin -c "get cluster status" | grep <uuid-of-manager-from-step-1>

Step 3. SSH into the identified NSX Manager node:

ssh root@<nsx-ip-from-2>

Step 4. Restart NSX manager

systemctl restart proton

Additional Information

If the resolution mentioned in this KB does not address your issue, refer to the Master KB for NSX Onboarding Issues, which lists all known onboarding scenarios, causes, and troubleshooting methods.