DevTest registry database is getting locked frequently after migrating Devtest version from 10.7.2 to 10.8.3.1
search cancel

DevTest registry database is getting locked frequently after migrating Devtest version from 10.7.2 to 10.8.3.1

book

Article ID: 414652

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

We are experiencing registry DB lock issue very frequently right after upgrading DevTest server version from 10.7.2 to 10.8.3.1.

In 10.8.3.1 Registry server , we have enabled the below property in site.properties,  but still we are facing the DB lock issue.

##=============================================================================================
## Should the Registry Database in the Workstation be connected?
##=============================================================================================
lisadb.workstation.enabled=false

 

Need help in identifying possible root causes which can lead to these DB lock. 

Environment

DevTest  10.8.3.1 

Workstations on 10.7.2 and 10.8.3.1

Cause

The Workstation has a pulse every 30 seconds to check if the connections it talks to are alive and creates an INFO level log statement, this includes a database ping.

After an Upgrade, If a User tries to connect without restarting the workstation OR if there are stale connections from  the old 10.7.2 Workstation,  this can cause DB locks. 

DBA logs were showing some users trying to access registry using 10.7.2 Workstation. 

Resolution

Please follow the below steps before Workstation connects to the Upgraded version of Registry: 

  1. Stop Workstation.
  2. Check Task Manager for any stalled instance of Workstation is running. 
  3. Delete the entire lisatmp10.7.x  logs folder in /Users folder.
  4. Start Workstation and Connect to the Registry. 

 

** Note:  With the property enabled in site.properties,  any tests or test suites run locally on the workstation (for example, quick stage a test or quick stage a test suite) will not be sent to the registry database without a workstation connection and, therefore, will not display in Monitor tests. 

** Enterprise Dashboard has Registry Reports that you can use to verify what versions of Workstations are connected to the Upgraded 10.8.3.x Registry.