License Hub Alarm: The license bundle processing failed on License Hub
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License Hub Alarm: The license bundle processing failed on License Hub

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Article ID: 414635

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Updated On:

Products

VMware vDefend Firewall VMware vDefend Firewall with Advanced Threat Prevention

Issue/Introduction

The presented license bundle contains at least one invalid license, hence it could be processed or saved in the License Hub.

 

Environment

License Hub 5.1.2

Cause

There can be multiple scenarios for rejecting the license bundle by License Hub:

  1. The license bundle is not signed by Broadcom.
  2. The license bundle is created for some other License Hub and is being tried to be uploaded to this License Hub.
  3. The license bundle contains some corrupted / invalid license.

 

For more details, please refer to logs using following steps.
Execute these on SSPI.

 

ssh sysadmin@SSPI-IP

# check the licensing-service pod
k -n nsxi-platform get pods | grep "licensing-service"

# see the logs for licensing-service pod
k -n nsxi-platform logs -f deployment/licensing-service

 

Sample error message for # 1 cause:

 

<179>1 2026-04-03T10:26:47Z licensing-service-69884f86f5-kjcnf SSP 1 SSP [ssp@4413 comp="SSP" level="ERROR" s2comp="service/file_processor_util.go:418" subcomp="SSP"] Failed to decode the license by GTO library. {"error":"common name validation failed: CN XXXX.YYYY.com was found"}
 :
<179>1 2026-04-03T10:26:47Z licensing-service-69884f86f5-kjcnf SSP 1 SSP [ssp@4413 comp="SSP" level="ERROR" s2comp="service/file_processor_util.go:123" subcomp="SSP"] Failed to process file {"error":"The license file contains at least one invalid license","fileName":"ff9d95a7-7746-4810-b90a-d82743dbe310_v4.lic"}

Resolution

Please contact customer support and share the license bundle.

When in connected mode, the license bundle can be downloaded from Avi Cloud Console.

Customer support contact : https://support.broadcom.com/web/ecx/software-contact-support