Risk Authentication Service becomes unresponsive
search cancel

Risk Authentication Service becomes unresponsive

book

Article ID: 414611

calendar_today

Updated On:

Products

CA Risk Authentication CA Advanced Authentication CA Advanced Authentication - Risk Authentication (RiskMinder / RiskFort)

Issue/Introduction

The Risk Authentication (RA) service suddenly becomes unresponsive across all instances.

Despite restarting the RA servers, telnet connectivity to port 7778 remains unsuccessful.

Hence, traffic is not flowing from the Load Balancer to the RA servers, resulting in service disruption.

Environment

Symantec Risk Authentication 9.1 SP4

Cause

Based on the process dump analysis, thread exhaustion has been observed on the Risk Auth servers.

Resolution

To address the issue it is recommended to reduce the `READTIMEOUT` value for the TransWS protocol (7778) using the following database query:

UPDATE ARRFPROTOCOLREGISTRY set READTIMEOUT=600000 where PORTNO=7778 and INSTANCEID='<instanceId of the server>';

Note:
The InstanceId for the server can be found in the ARRFPROTOCOLREGISTRY table. Please ensure you select the correct InstanceId, as this column may contain additional details such as the ARCOT_HOME path.