VCF Operations Cloud Proxy Offline
search cancel

VCF Operations Cloud Proxy Offline

book

Article ID: 414592

calendar_today

Updated On:

Products

VCF Operations

Issue/Introduction

  • Cloud Proxy is reporting as 'Offline' in the Cloud Proxies menu.
  • The same cloud proxy reports its Health Status in the VCP Operations Admin UI as 'Outdated life status'
  • The console for the Cloud Proxy in vCenter, as the error below;
    • [FAILED] Failed to start HAProxy Load Balancer.

Environment

VCF Operations 9.x

Cause

When haproxy starts, it attempts DNS resolution for the FQDNs listed in /etc/haproxy/haproxy.cfg.
FQDNs which do not exist in the DNS records lead to recursive queries being sent to the upstream DNS server, causing a timeout. This led to the haproxy startup process failing.
The issue may also occur due to an incorrect DNS entry within the Cloud Proxy VM's /etc/resolv.conf file.

Resolution

To resolve this issue, follow the below steps:

  • SSH into the Cloud Proxy appliance and update the /etc/resolv.conf file with the correct DNS entry.
  • Start the ' haproxy.service' using below command
    systemctl start haproxy.service
  • If the issue still persists, follow the steps outlined in the article below.

The firstboot of the VCF Operations Collector fails because HA Proxy does not start and times out