The message "Virtual Machine Consolidation Needed" appears for a specific virtual machine in the vSphere Client
search cancel

The message "Virtual Machine Consolidation Needed" appears for a specific virtual machine in the vSphere Client

book

Article ID: 414589

calendar_today

Updated On:

Products

VMware vCenter Server VMware vSphere ESXi VMware Telco Cloud Infrastructure

Issue/Introduction

  • When a specific virtual machine is selected in the vSphere Client, the following message appears in the "Issues and Alarms" section of the "Summary" tab:

    Virtual machine disks consolidation is needed.

  • Navigating to the "Snapshots" tab displays the following message at the top of the screen:

    Consolidation is required

Environment

  • VMware vSphere ESXi 7.x
  • VMware vSphere ESXi 8.x
  • VMware vCenter Server 7.x
  • VMware vCenter Server 8.x
  • TCI 2.2

Cause

This message appears when an inconsistency occurs between the snapshot manager's perception and the actual state of the snapshot files on the datastore.

Resolution

  1. Navigate to the virtual machine in the vSphere Client inventory and click the Snapshots tab.
  2. If the virtual machine snapshot files must be consolidated, the Consolidation is required message appears.
  3. Click the Consolidate button.
  4. The Consolidate dialog box appears.
  5. Click OK.

Additional Information

If snapshot consolidation fails, one of the following issues may be the cause:

  • Insufficient datastore space: There is not enough free space on the datastore to perform the consolidation. This often occurs when a VM disk resides on a datastore with less than 1 GB of available space.

  • Locked snapshot files: A third-party backup application has locked the snapshot file. As a result, the snapshot could not be deleted after a backup completed, or a scheduled backup failed to start.

  • Connectivity issues: There is an interrupted or degraded connection between the vCenter Server and the ESXi host.

  • Exceeded snapshot limits: The virtual machine has exceeded the number of snapshots recommended by VMware by Broadcom. Best practice guidelines suggest maintaining a maximum of 32 snapshots per guest VM.

Refer: 
Consolidate Snapshots
Consolidating/Committing snapshots in VMware ESXi

-------------------------------------------------------------------------------------------------

This alert/issue is also seen if the VM files are located in an NFS datastore and the snapshot consolidation fails due to underlying issue with the NFS plugin.

Refer the following KBs for more details:

https://knowledge.broadcom.com/external/article/380195

https://knowledge.broadcom.com/external/article/418244