Unable to Extend network after registering HCX to a new vCenter
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Unable to Extend network after registering HCX to a new vCenter

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Article ID: 414576

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Updated On:

Products

VMware HCX

Issue/Introduction

After registering a different vCenter on "HCX Manager Admin UI" Configuration > vCenter Server the effects include, but are not limited to:

  • Unable to extend network extensions on new Service Mesh, no networks get populated with error "No Source Networks Found for Selected Service Mesh"

  • Unable to delete old Service Mesh created on the original vCenter registration.

Cause

HCX leverages the unique identifiers (UUIDs) within the specific vCenter instance in order to manage the entire inventory of network and VM objects. Because of this, an existing HCX Cloud Manager or Connector cannot be registered to a different vCenter instance without database objects becoming out of sync. Attempting to do that will result in a UUID mismatch.

Resolution

  • Register HCX back to original vCenter server and follow the process to decommission HCX at Uninstalling VMware HCX
  • Deploy a new HCX for the new vCenter.

Additional Information

If the original vCenter is no longer available follow the resolution at HCX Recovery process after vCenter redeployment.