Unable to update Aria Operations for Logs using Aria Suite Lifecycle. Unable to login with root account at console.
search cancel

Unable to update Aria Operations for Logs using Aria Suite Lifecycle. Unable to login with root account at console.

book

Article ID: 414472

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • Unable to update Aria Operations for Logs using Aria Suite Lifecycle.
  • Unable to login with root at console.
  • Even after changing the password at GRUB using KB 319358, users still cannot login using root account.

Environment

Aria Operations for Logs 8.18.x

Cause

Extra entries in the system-account and system-auth files.

Resolution

  • Steps to follow:

    1. Console to the appliance and access the GRUB menu following the kb: How to reset the root password in VMware Aria Operations for Logs (formerly VMware vRealize Log Insight)
    2. Verify there are no extra entries are in the following two files:
      • /etc/pam.d/system-account:
        # Begin /etc/pam.d/system-account
        # Updated by Ansible - 2024-06-11T09:23:51.886414
        account    required pam_faillock.so
        account    required pam_unix.so
        # End /etc/pam.d/system-account
      • /etc/pam.d/system-auth
        # Begin /etc/pam.d/system-auth
        # Updated by Ansible - 2024-06-11T09:23:51.039431
        auth       required pam_faillock.so preauth
        auth       required pam_unix.so
        auth       required pam_faillock.so authfail
        auth       optional pam_faildelay.so delay=4000000
    3. Confirm you're able to login into the root account at console.