Compute Manager registration fails with error Compute manager with thumbprint value: already exists. (Error code: 7056)
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Compute Manager registration fails with error Compute manager with thumbprint value: already exists. (Error code: 7056)

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Article ID: 414449

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Updated On:

Products

VMware NSX

Issue/Introduction

"Compute manager with thumbprint value: "##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:##:" already exists. Existing compute manager with this thumbprint is ######-####-####-####-############ having server ##.###.##.### (Error code: 7056)

Environment

VMware NSX

Cause

This can happen if the NSX manager was previously registered to this or another compute manager and there is a stale thumbprint entry.

 

Resolution

Resoultion Steps:

  • Confirm the compute manager isn't registered in the NSX database by running either the API calls below or by running the curl commands directly from the NSX Manager cli in root mode.  Ensure the compute manager you are trying to register is not listed.
    API Calls:
              GET https://<nsx magr IP or VIP>/api/v1/fabric/compute-collections
         GET https://<nsx magr IP or VIP>//api/v1/fabric/compute-managers

    Curl Commands: *run from NSX manager via cli in root mode
              curl -k -v -u "admin" -X GET "https://<nsx magr IP or VIP>/api/v1/fabric/compute-collections"
         curl -k -v -u "admin" -X GET "https://<nsx magr IP or VIP>//api/v1/fabric/compute-managers"

    If there is data returned related to the compute manager you are trying to register from the commands above, there is a stale entry in the database.  Reference Compute Manager cannot be edited in NSX UI due to stale Transport Node Collection entry in Corfu

  • Confirm there isn't a NSX extension registered to the vcenter. 
         Log in to the vCenter Managed Object Browser (MOB) at https://<vCenter FQDN>/mob/?moid=ExtensionManager as a vCenter Server Administrator.
         Click on content, then ExtensionManager.
         Locate the com.vmware.nsx.management.nsxt extension in extensionList
    *If the NSX extension is listed, perform the following step in the MOB to unregister NSX with the vCenter:
         Click UnregisterExtension, paste com.vmware.nsx.management.nsxt into the value field, and click Invoke Method

  • If no entries are listed in the NSX UI, vCenter MOB or the database table output, reboot the vCenter server and perform a rolling reboot of the NSX Managers.

 

If the above steps do not resolve the issue, open a case with support. Creating and managing Broadcom support cases