How to enable HTTPclient logging for CA Access Gateway (SPS)
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Article ID: 41442
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Updated On:
Products
CA Single Sign On Secure Proxy Server (SiteMinder)CA Single Sign On SOA Security Manager (SiteMinder)CA Single Sign-On
Issue/Introduction
Introduction:
How to enable HTTPclient logging for CA Access Gateway (SPS)
Environment
Release: All versions of CA Access Gateway (SPS) Component: SMSPS
Cause
In order to see transactional information and runtime events of communication from the SPS to a backend application you would want to enable HTTPclient logging.
Resolution
Instructions:
Open the server.conf file found in \CA\secure-proxy\proxy-engine\conf\
Changehttpclientlog from its default value of no to yes. Looks like httpclientlog=yes.
Also, ensure that httpclient.wire.header.level=FINEST and httpclient.wire.level=FINEST
Restart the secure proxy and proxy engine for the changes to take effect.
The httpclient.log file will now be present in \CA\secure-proxy\proxy-engine\logs\