How to enable HTTPclient logging for CA Access Gateway (SPS)
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How to enable HTTPclient logging for CA Access Gateway (SPS)

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Article ID: 41442

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Updated On:

Products

CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On SOA Security Manager (SiteMinder) CA Single Sign-On

Issue/Introduction

Introduction: 

How to enable HTTPclient logging for CA Access Gateway (SPS)

Environment

Release: All versions of CA Access Gateway (SPS)
Component: SMSPS

Cause

In order to see transactional information and runtime events of communication from the SPS to a backend application you would want to enable HTTPclient logging.

Resolution

Instructions: (below applicable up till 12.8 SP8 CR01) 

  1. Open the server.conf file found in \CA\secure-proxy\proxy-engine\conf\
  2. Change httpclientlog from its default value of no to yes. Looks like httpclientlog=yes.
  3. Also, ensure that httpclient.wire.header.level=FINEST and httpclient.wire.level=FINEST
  4. Restart the secure proxy and proxy engine for the changes to take effect.
  5. The httpclient.log file will now be present in \CA\secure-proxy\proxy-engine\logs\

 

Starting with 12.9, the Http client was updated and the http client logs are now managed as follows 

Use the logger.properties file to configure the Access Gateway log settings.
From Release 12.9, use the file to configure the HttpClient log settings too.
 
The logger.properties file is located at <access-gateway-installation-path>/Tomcat/properties.
Please see the Official guide for more details Configure Access Gateway Log Settings