Live Site Recovery 9.0.3 vCenter Plug-in shows up even after unregistering the appliance
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Live Site Recovery 9.0.3 vCenter Plug-in shows up even after unregistering the appliance

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Article ID: 414417

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

After following the process to Unregister the VMware Live Recovery Appliance

The vCenter still shows VLSR 9.0.3 plugin under Administration > Client Plugins 

Environment

Live Site Recovery 9.0.3

Cause

Stale 'com.vmware.drui.plugin' extension in vCenter MOB.

The com.vmware.drui.plugin is the extension ID for the vSphere Replication plugin (also known as the Disaster Recovery UI).

While it is related to disaster recovery, it is not the main SRM extension, which is typically com.vmware.vcDr. We will need to remove both the plugin's.

Resolution

Warning: Before making changes in the MOB, create a snapshot of your vCenter Server to avoid data loss

Step-by-step instructions

1) Open a web browser and navigate to the vCenter Managed Object Browser (MOB). The URL is https://<vCenter_Server_name_or_IP>/mob.

   Log in using your vCenter Single Sign-On (SSO) administrator credentials (e.g., [email protected]).

2) On the MOB main page, click Content and then Click on ExtensionManager.

3) On the ExtensionManager page, find the com.vmware.drui plugin entry in the list of properties. You can click on the plugin to view more details, like the server IP, to confirm it is for a decommissioned instance.

4) Once you have confirmed it is a stale entry, navigate back to the ExtensionManager page and scroll to the bottom.

5) Click the UnregisterExtension method. A new window will appear.

6) In the Value field, paste the exact extension key: com.vmware.drui.plugin.

7) Click Invoke Method. The result should show void, which indicates that the method was successful.

8) Refresh the ExtensionManager page to verify that the com.vmware.drui plugin is no longer listed.


To ensure the plugin is completely removed from the vSphere Client UI, restart the vsphere-ui service on your vCenter Server.

Access vCenter via SSH: ssh root@<vCenter_Server_name_or_IP>.

Restart the service: service-control --restart vsphere-ui.

Log out and back into the vSphere Client to see the changes reflected in the UI.