SPS and UpdateManager services not starting
book
Article ID: 414404
calendar_today
Updated On:
Products
VMware vCenter Server
Cause
- Solution users to authenticate these services are missing, are incorrect or do not have permissions
- The root cause/fix for this error may be one or all of the steps below, so please run through all of them to validate it
Resolution
Missing solution users:
- To investigate if your solution users are missing please use 'lsdoctor -u' as explained here
- If the solution users are missing the script will detect it and will recreate them
- take note of the numbering after the solution users type such as vpxd-XXXXXX
- restart all services and confirm if the issue is resolved
Missing or duplicate permissions:
- This error also can happen if there are duplicate permissions for the user Administrator so kindly review it here
- if the step1 does not show any duplicate entry please follow the next section
Incorrect solution users:
- after recreating the solution users (the script always recreate them either they are missing or not) please open the vcenter UI
- Go to Administration > Global Permissions
- search for 'vpxd' (you should have one entry for each vcenter in link mode and the numbering should match vpxd-XXXX as per the users recreated before)

- Taking this case as example for 2 vcenters in ELM we can see 2 entries but one does not match with our faulty vcenter
- change the filter from 'vpxd' to the incorrect node UUID (vpxd-XXXX)
Note: Take in consideration to only filter with numbers and not the 'vpxd-'
- the results should now show several solution users for that incorrect node
- select one by one and remove them
- Press 'ADD' and search by the correct UUID as seen on step3
- Add all existing solution users with the correct node UUID and check the box to 'propagate permissions to children'
- start services with:
service-control --start sps
service-control --start updatemgr

Feedback
thumb_up
Yes
thumb_down
No