Error: "VM could not be started"
search cancel

Error: "VM could not be started"

book

Article ID: 414342

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

  • ESXi host could not be rebooted
  • VM could not be started 
  • There is missing logging for 4 days before the issue occurred when checking vmkernel.log
    In(182) vmkernel: cpu##:#####)NetPort: 708: Failed to acquire port non-exclusive lock 0x6000041[Failure].
    In(182) vmkernel: VMB: 65: Reserved 4 MPNs starting @ 0x4c4

Environment

VMware vSphere ESXi 8.X

Vmware vSphere ESXi 7.X

Cause

  • ESXi host locked up and stopped logging and it went not responding in the vCenter around the timestamp 

Resolution

  • If another occurrence happens again check if logging under /var/log are up to date with command below 
    ls -lthra 
  • OR 
    tail vmkernel.log and date command
  • If the logs are not up to date engage Hardware vendor to assist with sending an NMI to the ESXi host. Read more at Using hardware NMI facilities to troubleshoot unresponsive hosts
  • Once the dump has been collected, open a case with Broadcom and provide the dump