VCHA configuration fails with an error "vCenter HA has an invalid configuration. Remove vCenter HA to destroy the current cluster configuration and set up vCenter HA again"
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VCHA configuration fails with an error "vCenter HA has an invalid configuration. Remove vCenter HA to destroy the current cluster configuration and set up vCenter HA again"

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Article ID: 414289

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When configuring vCenter High Availability (VCHA), the configuration fails with the following error message:
    • vCenter HA has an invalid configuration. Remove vCenter HA to destroy the current cluster configuration and set up vCenter HA again

  • Passive nodes is successfully deployed. 
  • Witness node deployment will fails to initiate. 
  • From /var/log/vmware/vcha/sshconnect.log  (From active vcha node)

    • 2025-10-08T17:20:22.1062 WARNING sshConnect retry attempt 238 failed [Errno None] Unable to connect to port 22 on <Passive node vSphere HA IP address>
      2025-10-08T17:20:27.111Z INFO sshConnect Retry attempt 238
      2025-10-08T17:20:27.119Z WARNING sshConnect retry attempt 239 failed [Errno None] Unable to connect to port 22 on <Passive node vSphere HA IP address>
      2025-10-08T17:20:32.124Z INFO sshConnect Retry attempt 239
      2025-10-08T17:20:32.133Z WARNING sshConnect retry attempt 240 failed [Errno None] Unable to connect to port 22 on <Passive node vSphere HA IP address>
      2025-10-08T17:20:37.137Z INFO sshConnect Retry attempt 240

  • From /var/log/vmware/vpxd/vpxd.log
    • 2025-10-08T17:17:06.840Z info vpxd[09246] [Originator@6876 sub=vpxLro opID=sps-Main-920647-707-920679-1] [VpxLRO] -- FINISH 1ro-5427456
      2025-10-08T17:17:06.8492 info vpxd[07270]
      -> Spec: {
      'active": {
      "ha_ip": {
      "default gateway": ""
      "dns servers": null,
      "ip_family": "IPV4",
      "ipv4": {
      "address": "<Active node vSphere HA IP address>",
      "prefix": null,
      "subnet mask": "<Subnet Mask>"
      "ipv6": null
      "ha network": null,
      "ha_network_type": null

      "deployment": "AUTO",
      "passive": {
      "failover_ip": null,
      "ha_ip": (
      "default_gateway": null,
      "dns_servers": null,
      "ip_family": "IPV4",
      "ipv4": {
      "address": "<Passive node vSphere HA IP address>"
      "prefix": null,
      "subnet mask": "<Subnet Mask>"
      mipv6": null

      "placement": {
      "folder": "group-v3:3c3e5f3a-9e70-4e45-b697-3e41eb000adb"
      "ha_network": "dvportgroup-21070:3c3e5f3a-9e70-4e45-b697-3e41eb000adb",
      "ha_network_type": "DISTRIBUTED_PORTGROUP",
      "host": null,
      "management_network": "dvportgroup-21066:3c3e5f3a-9e70-4e45-b697-3e41eb000adb",
      "management network type": "DISTRIBUTED PORTGROUP",
      "name": "pavcsifgm02-Passive",
      "resource pool": "resgroup-21057:3c3e5f3a-9e70-4e45-b697-3e41eb000adb",
      "storage": {
      "datastore": "datastore-33473:3c3e5f3a-9e70-4e45-b697-3e41eb000adb"

Environment

  • VMware vCenter Server Appliance 7.X
  • VMware vCenter Server Appliance 8.X

Cause

  • This issue is caused by an incorrect configuration of the vSphere HA network IP address during the vCenter HA (VCHA) setup. Specifically, the passive and witness node IP addresses are not configured or are configured incorrectly, preventing proper communication between the nodes over port 22.

Resolution