We cannot browse an accessible datastore from vCenter Server
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We cannot browse an accessible datastore from vCenter Server

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Article ID: 414237

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

There are several reasons that you may not be able to browse an inaccessible datastore, however if the datastore is still browsable from the Host UI or the Host SSH session then we can confirm that this is an issue with vCenter connectivity to the host. To see if this is the issue you are facing you will need to: 

  1. Test that you can brose the files from the host 
  2. Check the vCenter vpxd logs for invalid log in errors. 

To test if you can browse the files from the host: 

  1. Open a web browser and go to https://[IP of ESXi Host]/ui
  2. Log in with your ESXi credentials.
  3. In the navigator pane on the left, click Datastores to see a list of your datastores.
  4. Right-click a datastore and select Browse Files, or select the datastore and navigate to Manage > Files.

If you can see and browse the files here but not in the vCenter client then this could be being caused by the vCenter attempting to log in to the host with the wrong ESXi credentials. To confirm that this is the case, open an SSH session to the vCenter: 

  1. Open an SSH session to vCenter
  2. Check the vpxd log located at: /var/log/vmware/vpxd/vpxd.log 
    1. You will see the following error: 

      YYYY-MM-DDTHH:MM:SS.Z warning vpxd[#####] [Originator@#### sub=InvtHostCnx opID=HostSync-host-######-######] Exception occurred during host sync; Got method fault; [vim.HostSystem:host-######, 10.##.##.##], e: N3Vim5Fault12InvalidLogin9ExceptionE(Fault cause: vim.fault.InvalidLogin
      --> 

 

Environment

VMware vCenter Server 9.x

VMware vCenter Server 8.x

VMware vCenter Server 7.x

Cause

Whenever you restart the management agents, reboot the vCenter, or restart the vpxd agent, vCenter randomly chooses a host to start services on. When the host is chosen, vCenter will log in to the host with the latest credentials. However, if the password has been changed or lost (this can happen due to snapshots, backups, or rollbacks) then we cannot start the management agents on the host. 

 

This leads to several issues but since vCenter uses the management agents to communicate with the host, this will lead to us being unable to browse the datastore from the vCenter. It can also impact backups and prevent HA from functioning properly since it will prevent services from starting. 

Resolution

To resolve this: 

  • Place the problem host into maintenance mode. 
  • Disconnect the host from vCenter
    • Navigate to HomeHosts and Clusters and select a host.
    • Right-click the host and select Connection > Disconnect from the pop-up menu.
    • In the confirmation dialog box that appears, click Ok.
  • Reconnect the host to vCenter
    • Navigate to HomeHosts and Clusters and select a host.
    • Right-click the host and select Connection > Connect from the pop-up menu.
      • At that point it will prompt you for a password and you can resolve the password conflict

Additional Information

If you cannot browse the files from the Host UI then see: Datastore shows inaccessible state in vCenter and investigate the backend disconnection to the LUN