Unable to send usage data from Usage Meter to the VCF Business Portal with error Test Failed due to "Http failure response for https://##.##.##.##/api/v1/run_uploader: 500 OK"
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Unable to send usage data from Usage Meter to the VCF Business Portal with error Test Failed due to "Http failure response for https://##.##.##.##/api/v1/run_uploader: 500 OK"

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Article ID: 414173

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Updated On:

Products

VMware Usage Meter

Issue/Introduction

Attempts to send usage data consistently result in an error :

VCF Business Services console Test Failed due to "Http failure response for https://##.##.##.##/api/v1/run_uploader: 500 OK". Please open a ticket with Broadcom support at https://support.broadcom.com/
 

Environment

VCF Usage Meter 9.x

Cause

Usage Meter's hostname has been configured with a short name instead of fully qualified domain name (FQDN) which is referenced in the certificates, and also A and PTR records are missing in the DNS server.

Resolution

In order to ensure successful upload of usage data, follow the below steps:
  1. Change the usage meter's short name to FQDN, following the procedures outlined in below KB:
    How to change hostname in Usage Meter 9.0
  2. Following the hostname change, replace the certificates in the environment as per the Usage Meter 9.0 certificate replacement procedure:
    VCF Usage Meter Certificate Management
  3. Ensure both forward and reverse DNS lookup works for the usage meter appliance when checked with nslookup command. Based on this output, required to update the A and/or PTR records in DNS server.

Additional Information