Pingable models not resolving to switch ports after running Spectrum AutoDiscovery
search cancel

Pingable models not resolving to switch ports after running Spectrum AutoDiscovery

book

Article ID: 41409

calendar_today

Updated On:

Products

CA Spectrum

Issue/Introduction

After running an AutoDiscovery, the Pingable models are not being resolved to the switch ports as expected.

Environment

Release: Any
Component: Spectrum Discovery

Cause

The root cause could be 1 of the following:

  • The AutoDiscovery configuration does not have the "ARP Table for Pingables" Protocol Option selected
  • There is no layer 3 device modeled in the Spectrum database that is in the same subnet as the Pingable device
  • There is a layer 3 device modeled in the Spectrum database that is in the same subnet as the Pingable but that ip address is not in the ARP cache of the layer 3 device

Resolution

In order for Spectrum to associated a mac address to a Pingable model, the following two criteria must be met:

1. The "ARP Tables for Pingables" must be selected under;

AutoDiscovery Console -> Modeling Options (Discover and automatically model to SPECTRUM) -> Protocol Options:


 

2. A layer 3 device in the same subnet as the Pingable model must be modeled in the Spectrum database

 

When the "ARP Tables for Pingables" modeling protocol is selected, Spectrum looks for a layer 3 model that is in the same subnet as the Pingable model. If found, Spectrum reads the ipNetToMediaTable from the device to resolve a mac address to the ip address of the Pingable model. If resolved, the MAC_Address attribute id 0x110df on the Pingable model will be populated. 

Additional Information

Please reference the "How to Discover and Model the Network" section of the documentation for more information.